Charging, suction and maintenance issues on your FX9 or Pure F9 vacuum cleaners

Last updated 27/09/2023 05:45

Issue

  • Charging the vacuum takes too long or not charging at all
  • Suction is poor
  • Stick vacuum maintenance
  • How to clean the vacuum cleaner filters?

Applies to

  • FX9 stick vacuum cleaners family 
  • Pure F9 stick vacuum cleaners family

Resolution

How to charge 

After use, place your FX9 on the charging station and make sure the nozzle lights blink twice


  

Remember it may take 6 hours for a full charge.

If the above does not solve the problem, we recommend that you contact customer service on 03445 611 611 to help you solve the problem.

Poor suction issue:

Check for blockages and cut the hair from the brush roll.

Maintenance & Filters:

Dustbin needs to be emptied from time to time for the best performance and filters need to be washed every 2 months


So don't forget open-empty-dispose.

Please note that the dustbin HEPA filter paper filter and cyclone filter are not to be washed in a dishwasher


Cause

  • Battery issues
  • Blockage
  • Forget to empty the dustbin
  • Change or replace filters
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